summaryrefslogtreecommitdiff
path: root/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild')
-rw-r--r--kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild b/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
new file mode 100644
index 000000000000..752aaaa3ea53
--- /dev/null
+++ b/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Akonadi resource for Microsoft Exchange Web Services"
+HOMEPAGE="https://github.com/KrissN/akonadi-ews"
+
+if [[ ${KDE_BUILD_TYPE} = live ]] ; then
+ EGIT_REPO_URI="https://github.com/KrissN/${PN}.git"
+else
+ SRC_URI="https://github.com/KrissN/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"
+
+DOCS=( README.md )