summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /kde-frameworks/syntax-highlighting
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest2
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 52497c0dd487..98f46e0316d1 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,3 +1,5 @@
DIST syntax-highlighting-5.70.0.tar.xz 1606544 BLAKE2B 573a16979e9d2adff8562312c7681acbfbfaac906cf5eef2b1c8ae4131a555b89e4900d0d0e63b1a2fab3ac535e7c2daf0d847637d16d9eed9f4a07b30554c53 SHA512 59a05fd274cb11b893351cc10747600e03ced88cdc738eee26689e9a2a97b07db05805c0b0dcadbf02809254bd170b04f27b8372abb26b769bc6e962c615b9e0
+DIST syntax-highlighting-5.71.0.tar.xz 1611320 BLAKE2B 4790a9bbc956d1ad2b723cd34c67a9a9c7b5d3a8ad82b0f5f8fc385ff9f89dfce79e2e940f456b589b567c98debbc366d211da982bd8199c53604bc0a24d6592 SHA512 d2d79821172e59ced6de1053960d265c96cd08897cc638b6a64ea412364490b8857661a48b710bfb0906bbb2b9749cff867fbfc23767558fc26f9e9c535d8e17
EBUILD syntax-highlighting-5.70.0.ebuild 567 BLAKE2B 6f5bdba5013444f0399ebe811837b0d39063a6523500d4f293c0bef285baf47f12908fcb10af63ee0274e287ad698e33f0424a89f06db5e5e18cdf94a7bef93e SHA512 0cd9691816351924347d9621e5b61799b0499267410ed6910162694ff7354bd35150f9335ee204297c982475eac0a4b16a4923fde4daf3f5d6b263971869f2c6
+EBUILD syntax-highlighting-5.71.0.ebuild 570 BLAKE2B 56dde8d8bbd9425cc090cd31cfabab95156d7673024a46e96d5b758a64c70bd1b23ab4dc03ba59d51c1769cf64223db274918b3040b604c70cefe42b7b98b53d SHA512 fad33c6b69290316cedaa60e70cb45290d7931cc9637b28a81bc99fb226931a07f4c6bab1c16665f53d527ec5e91153f8e36e73de4f9d93bd633ccc1b154198b
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild
new file mode 100644
index 000000000000..9e72dae4c24b
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.71.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}