summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /kde-frameworks/syntax-highlighting
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest2
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.109.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 7eb58a8b42b6..02354c421c24 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,3 +1,5 @@
DIST syntax-highlighting-5.108.0.tar.xz 3428404 BLAKE2B af4e6361eac58e05324e32f1de166369db167d7e552bb97f48b73a1a5f08c12ab1b2ee997e0949c4810cd14ce09d79b38253bab01fbb2b2c252c339ee4288e5b SHA512 70a285a283da85eb631df1c2b88207915e2e287b16eff5537c743647d473742013728e3f381f335a92766bdf61d9d8a24ca1c7f557b4db076d2ee012703a62e8
+DIST syntax-highlighting-5.109.0.tar.xz 3430120 BLAKE2B 6dbb3c694971a72f629e62cb1e9967e4cf15cc1398957b79be7952dbdb60061fc94785c0dd4547d7838e44689e6936af382d1ba044c128cfd0ef4971b1530ee5 SHA512 bd8050dba60383d055cb9fd13948cd1b7117030ac63a67ce0e1bb0e474207f0fb594baa9b796f0e411e6e49bd2e4b9cd6caca3db6889485f5b491cf6703c352f
EBUILD syntax-highlighting-5.108.0.ebuild 616 BLAKE2B 8111b7e8a2f24cb92bc4b470cf0472ca3649ef1e26fe5704f5866acdefbb21774b89c1ff5aa16ca03df00aa8a15bc890db68d8ce47cd998b5595b5c566b6c499 SHA512 ef2411f84cf4fb6c6d73340aa35e2a62d17a12adae95880d8ecdf9e7a1efd72d52887a910be393d6e4dd0021119dedfa1f94e7f77a3ca7a2bd26e33953d92105
+EBUILD syntax-highlighting-5.109.0.ebuild 607 BLAKE2B c9767654d02521e57cb0f92b11e62c7f4ddda50484eb3fe70a91a0a934367dd60002b83b295d74664bdbb44f1853dd568c44182137b63c9d98e487afdf37443e SHA512 513d5b5d7574bfc438d1e16b8131f05c5134fd48a12764d86d37a49ace092e1bdecf78031fb1a9f2e4573f0fdec1ae7552ee293b753f76a48a669c08442ca3fe
MISC metadata.xml 456 BLAKE2B 4392b1cc6f304778d71236d5eb557dfbbd530143eea5cad9a3c3034e3e8b22c835f6c7f980124a21cefd35a2dd1efd5110adc0a5342170f88dfd7418b12bee99 SHA512 7ba65331cad434e2dceee012a5458d268eb2a04e0f7276b265c15644e6db5209bc7eee7d9695aa0038c435711e0f6f0dc53c7bae9d773b48f01e22a22e4dbb80
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.109.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.109.0.ebuild
new file mode 100644
index 000000000000..9e608bb9c331
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.109.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ >=dev-qt/linguist-tools-${QTMIN}:5
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}