summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild
new file mode 100644
index 000000000000..dcea91c13a70
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.46.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxmlpatterns)
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_install() {
+ kde5_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}