summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet/sonnet-5.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /kde-frameworks/sonnet/sonnet-5.70.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.70.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.70.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.70.0.ebuild b/kde-frameworks/sonnet/sonnet-5.70.0.ebuild
new file mode 100644
index 000000000000..93eac7f8dfbf
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.70.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}