summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet/sonnet-5.39.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
commit0fdd4074ff3dc0c507a9867380a4f91250a0b610 (patch)
tree83d3b64438d2f29b375d895f12b82d5c484db219 /kde-frameworks/sonnet/sonnet-5.39.0.ebuild
parent8fbd420dce8836e6503b162092e07b6a77a89f1d (diff)
gentoo resync : 15.10.2017
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.39.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.39.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.39.0.ebuild b/kde-frameworks/sonnet/sonnet-5.39.0.ebuild
new file mode 100644
index 000000000000..f55dd0abe50d
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.39.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}