summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet/sonnet-5.249.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 23:44:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 23:44:31 +0000
commitc641f12d6bd92a8ea812f9b0e68a9a525a9c9ecc (patch)
tree87930b7fd113ac54da0b92db8b9df7652d5595e4 /kde-frameworks/sonnet/sonnet-5.249.0.ebuild
parent22230e510e031a97cafc85353610e573b7508e98 (diff)
gentoo auto-resync : 01:02:2024 - 23:44:31
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.249.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.249.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.249.0.ebuild b/kde-frameworks/sonnet/sonnet-5.249.0.ebuild
new file mode 100644
index 000000000000..a444c4c67998
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.249.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="aspell +hunspell qml"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:6 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+CMAKE_SKIP_TESTS=(
+ # bug 779994
+ sonnet-test_autodetect
+ # bug 680032
+ sonnet-test_settings
+ sonnet-test_highlighter
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ -DSONNET_USE_QML=$(usex qml)
+ )
+
+ ecm_src_configure
+}