summaryrefslogtreecommitdiff
path: root/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'kde-frameworks/purpose/purpose-6.3.0-r1.ebuild')
-rw-r--r--kde-frameworks/purpose/purpose-6.3.0-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild b/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
deleted file mode 100644
index 6e2d7f0e76de..000000000000
--- a/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_QTHELP="false"
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-2)
-QTMIN=6.6.2
-inherit ecm frameworks.kde.org optfeature xdg-utils
-
-DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
-
-LICENSE="LGPL-2.1+"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-IUSE="bluetooth webengine"
-
-# requires running environment
-RESTRICT="test"
-
-DEPEND="
- >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
- >=dev-qt/qtdeclarative-${QTMIN}:6
- =kde-frameworks/kconfig-${PVCUT}*:6
- =kde-frameworks/kcoreaddons-${PVCUT}*:6
- =kde-frameworks/ki18n-${PVCUT}*:6
- =kde-frameworks/kio-${PVCUT}*:6
- =kde-frameworks/kirigami-${PVCUT}*:6
- =kde-frameworks/knotifications-${PVCUT}*:6
- =kde-frameworks/kservice-${PVCUT}*:6
- =kde-frameworks/prison-${PVCUT}*:6
- webengine? (
- kde-apps/kaccounts-integration:6
- >=net-libs/accounts-qt-1.16_p20220803[qt6]
- )
-"
-RDEPEND="${DEPEND}
- !${CATEGORY}/${PN}:5[-kf6compat(-)]
- >=kde-frameworks/kdeclarative-${PVCUT}:6
- bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
- webengine? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
-"
-BDEPEND="webengine? ( dev-util/intltool )"
-
-src_prepare() {
- ecm_src_prepare
-
- use bluetooth ||
- cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package webengine KAccounts6)
- )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- optfeature "Send through KDE Connect" kde-misc/kdeconnect
- fi
- ecm_pkg_postinst
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}