summaryrefslogtreecommitdiff
path: root/kde-frameworks/prison/prison-5.55.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /kde-frameworks/prison/prison-5.55.0.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'kde-frameworks/prison/prison-5.55.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.55.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.55.0.ebuild b/kde-frameworks/prison/prison-5.55.0.ebuild
new file mode 100644
index 000000000000..ebcb4c899a7c
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.55.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( $(add_qt_dep qtdeclarative) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package qml Qt5Quick)
+ )
+
+ kde5_src_configure
+}