summaryrefslogtreecommitdiff
path: root/kde-frameworks/prison/prison-5.54.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /kde-frameworks/prison/prison-5.54.0.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'kde-frameworks/prison/prison-5.54.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.54.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.54.0.ebuild b/kde-frameworks/prison/prison-5.54.0.ebuild
new file mode 100644
index 000000000000..399b320a7630
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.54.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( $(add_qt_dep qtdeclarative) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package qml Qt5Quick)
+ )
+
+ kde5_src_configure
+}