summaryrefslogtreecommitdiff
path: root/kde-frameworks/plasma/plasma-5.102.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 18:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 18:05:24 +0100
commitcf59cc78468c9bcfef9e16b7b27c115896d805fd (patch)
treeb46b602c381e3a5e35654cf39e71673c96e49362 /kde-frameworks/plasma/plasma-5.102.0-r3.ebuild
parent5b52b99ca475070991d8e8d1dff674ffe6ffdea9 (diff)
gentoo auto-resync : 22:04:2023 - 18:05:23
Diffstat (limited to 'kde-frameworks/plasma/plasma-5.102.0-r3.ebuild')
-rw-r--r--kde-frameworks/plasma/plasma-5.102.0-r3.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/kde-frameworks/plasma/plasma-5.102.0-r3.ebuild b/kde-frameworks/plasma/plasma-5.102.0-r3.ebuild
deleted file mode 100644
index 4980673a1fab..000000000000
--- a/kde-frameworks/plasma/plasma-5.102.0-r3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-KDE_ORG_NAME="${PN}-framework"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
-inherit ecm frameworks.kde.org
-
-DESCRIPTION="Plasma framework"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="gles2-only man wayland"
-
-RESTRICT="test"
-
-# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
-RDEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5[gles2-only=,X]
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtsql-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- =kde-frameworks/kactivities-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5[qml]
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kdeclarative-${PVCUT}*:5
- =kde-frameworks/kglobalaccel-${PVCUT}*:5
- =kde-frameworks/kguiaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/kirigami-${PVCUT}*:5
- =kde-frameworks/knotifications-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- x11-libs/libX11
- x11-libs/libxcb
- !gles2-only? ( media-libs/libglvnd[X] )
- wayland? (
- =kde-frameworks/kwayland-${PVCUT}*:5
- media-libs/libglvnd
- )
-"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
-"
-BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-flicker-on-fade-animation.patch" # KDE-bug 463061, 463685
- "${FILESDIR}/${P}-fix-calc-of-distance-betw-dialog-and-parent-applet.patch" # KDE-bug 464201, 464513
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package !gles2-only OpenGL)
- $(cmake_use_find_package man KF5DocTools)
- $(cmake_use_find_package wayland EGL)
- $(cmake_use_find_package wayland KF5Wayland)
- )
-
- ecm_src_configure
-}