summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild')
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild
new file mode 100644
index 000000000000..f6d5e6b0bc5e
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.37.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="nls X"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-proto/xproto )
+"
+
+RESTRICT+=" test"
+
+DOCS=( "docs/README.kstartupinfo" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}