summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwayland/kwayland-5.61.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /kde-frameworks/kwayland/kwayland-5.61.0.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.61.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.61.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.61.0.ebuild b/kde-frameworks/kwayland/kwayland-5.61.0.ebuild
new file mode 100644
index 000000000000..d1a1dd1b09f1
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.61.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://cgit.kde.org/kwayland.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui 'egl')
+ >=dev-libs/wayland-1.15.0
+ media-libs/mesa[egl]
+ >=dev-libs/wayland-protocols-1.15
+"
+RDEPEND="${DEPEND}
+ $(add_qt_dep qtwayland 'egl(+)')
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"