summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwayland/kwayland-5.102.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
commitbdc9b55c978e3939e16252e66e83950cbecbf77c (patch)
treeabab17826fc88c33d1b30eadaec18fcc6f2efb14 /kde-frameworks/kwayland/kwayland-5.102.0.ebuild
parent3bd85407abc9ed4434c2d3741f84fdb512638b1c (diff)
gentoo auto-resync : 15:01:2023 - 05:54:04
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.102.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.102.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.102.0.ebuild b/kde-frameworks/kwayland/kwayland-5.102.0.ebuild
new file mode 100644
index 000000000000..3f4ad020e46a
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.102.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.9.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+"