summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpty/kpty-5.65.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /kde-frameworks/kpty/kpty-5.65.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'kde-frameworks/kpty/kpty-5.65.0.ebuild')
-rw-r--r--kde-frameworks/kpty/kpty-5.65.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.65.0.ebuild b/kde-frameworks/kpty/kpty-5.65.0.ebuild
new file mode 100644
index 000000000000..9b3b76a72174
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.65.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+ >=kde-frameworks/ki18n-${PVCUT}:5
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
+ )
+
+ ecm_src_configure
+}