summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpty/kpty-5.54.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /kde-frameworks/kpty/kpty-5.54.0.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'kde-frameworks/kpty/kpty-5.54.0.ebuild')
-rw-r--r--kde-frameworks/kpty/kpty-5.54.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.54.0.ebuild b/kde-frameworks/kpty/kpty-5.54.0.ebuild
new file mode 100644
index 000000000000..6d3f26dab1cd
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.54.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
+ )
+
+ kde5_src_configure
+}