summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpty/kpty-5.52.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /kde-frameworks/kpty/kpty-5.52.0.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'kde-frameworks/kpty/kpty-5.52.0.ebuild')
-rw-r--r--kde-frameworks/kpty/kpty-5.52.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.52.0.ebuild b/kde-frameworks/kpty/kpty-5.52.0.ebuild
new file mode 100644
index 000000000000..6d849595ca20
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.52.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
+ )
+
+ kde5_src_configure
+}