summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpeople/kpeople-5.99.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
commitbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (patch)
tree4a2377c9096a6e85935bc1b24a50c09537fbb3ca /kde-frameworks/kpeople/kpeople-5.99.0.ebuild
parentf69024d0d689548234c6173dc2d8a5bb466b0525 (diff)
gentoo auto-resync : 10:10:2022 - 13:34:00
Diffstat (limited to 'kde-frameworks/kpeople/kpeople-5.99.0.ebuild')
-rw-r--r--kde-frameworks/kpeople/kpeople-5.99.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/kpeople-5.99.0.ebuild b/kde-frameworks/kpeople/kpeople-5.99.0.ebuild
new file mode 100644
index 000000000000..a674e988f0fa
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-5.99.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://invent.kde.org/frameworks/kpeople"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # personsmodeltest segfaults, bug 668192
+ local myctestargs=(
+ -j1
+ -E "(persondatatest)"
+ )
+
+ ecm_src_test
+}