summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpackage/kpackage-5.106.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
commita0e652963f4d02b0e7c1148509f4ce3327c83808 (patch)
tree621db73bed25195d82efb6891ac2634295949450 /kde-frameworks/kpackage/kpackage-5.106.0.ebuild
parent724570cf64d3eddb687d69ef236582cdd6363fb4 (diff)
gentoo auto-resync : 13:05:2023 - 21:59:42
Diffstat (limited to 'kde-frameworks/kpackage/kpackage-5.106.0.ebuild')
-rw-r--r--kde-frameworks/kpackage/kpackage-5.106.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/kpackage-5.106.0.ebuild b/kde-frameworks/kpackage/kpackage-5.106.0.ebuild
new file mode 100644
index 000000000000..b8d5fa3dc183
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.106.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # plasma-plasmoidpackagetest bug 650214
+ # testpackage-appstream requires network access
+ local myctestargs=( -E "(plasma-plasmoidpackagetest|testpackage-appstream)" )
+ ecm_src_test
+}