summaryrefslogtreecommitdiff
path: root/kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild')
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild
new file mode 100644
index 000000000000..80cca1ceeaad
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.82.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="phonon"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !phonon Canberra)
+ )
+ ecm_src_configure
+}