summaryrefslogtreecommitdiff
path: root/kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
commita0e652963f4d02b0e7c1148509f4ce3327c83808 (patch)
tree621db73bed25195d82efb6891ac2634295949450 /kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild
parent724570cf64d3eddb687d69ef236582cdd6363fb4 (diff)
gentoo auto-resync : 13:05:2023 - 21:59:42
Diffstat (limited to 'kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild')
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild
new file mode 100644
index 000000000000..90bb1882010e
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.106.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="phonon"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !phonon Canberra)
+ )
+ ecm_src_configure
+}