summaryrefslogtreecommitdiff
path: root/kde-frameworks/kio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-27 13:17:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-27 13:17:14 +0000
commitb44896ea03d59328305f2dc8fb8987b21983cfb2 (patch)
tree79d011b3f463370ad56a3076c5fe0f6945fcbc3c /kde-frameworks/kio/files
parenta6f269cfc68657e7ab057411d29bf695822c011b (diff)
gentoo auto-resync : 27:11:2022 - 13:17:13
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-5.96.0-fix-RAW-file-image-preview.patch37
-rw-r--r--kde-frameworks/kio/files/kio-5.96.0-fix-crash-in-dropjob.patch45
-rw-r--r--kde-frameworks/kio/files/kio-5.96.0-with_x11.patch72
3 files changed, 0 insertions, 154 deletions
diff --git a/kde-frameworks/kio/files/kio-5.96.0-fix-RAW-file-image-preview.patch b/kde-frameworks/kio/files/kio-5.96.0-fix-RAW-file-image-preview.patch
deleted file mode 100644
index 12d4a4c05f2d..000000000000
--- a/kde-frameworks/kio/files/kio-5.96.0-fix-RAW-file-image-preview.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 5002a07e71ff270a8717911b965a75c33993f883 Mon Sep 17 00:00:00 2001
-From: Alexander Lohnau <alexander.lohnau@gmx.de>
-Date: Fri, 8 Jul 2022 11:00:42 +0200
-Subject: [PATCH] Fix thumbnailer result for parent mime types being
- overwritten
-
-BUG: 453480
----
- src/widgets/previewjob.cpp | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/src/widgets/previewjob.cpp b/src/widgets/previewjob.cpp
-index c53bcc88a..91be5575e 100644
---- a/src/widgets/previewjob.cpp
-+++ b/src/widgets/previewjob.cpp
-@@ -384,11 +384,13 @@ void PreviewJobPrivate::startPreview()
- }
- }
-
-- // Check the wildcards last, see BUG 453480
-- QString groupMimeType = mimeType;
-- static const QRegularExpression expr(QStringLiteral("/.*"));
-- groupMimeType.replace(expr, QStringLiteral("/*"));
-- pluginIt = mimeMap.constFind(groupMimeType);
-+ if (pluginIt == mimeMap.constEnd()) {
-+ // Check the wildcards last, see BUG 453480
-+ QString groupMimeType = mimeType;
-+ static const QRegularExpression expr(QStringLiteral("/.*"));
-+ groupMimeType.replace(expr, QStringLiteral("/*"));
-+ pluginIt = mimeMap.constFind(groupMimeType);
-+ }
- }
-
- if (pluginIt != mimeMap.constEnd()) {
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.96.0-fix-crash-in-dropjob.patch b/kde-frameworks/kio/files/kio-5.96.0-fix-crash-in-dropjob.patch
deleted file mode 100644
index 638a03f6eb98..000000000000
--- a/kde-frameworks/kio/files/kio-5.96.0-fix-crash-in-dropjob.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 29bdf541aa83c78bc8e9d90487a7e1dd505ef013 Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Fri, 8 Jul 2022 15:46:11 +0100
-Subject: [PATCH] Fix crash in DropJob
-
-QMimeData is owned by the backend and can be deleted during any event
-processing.
-
-DropJob has a deferred start operation. One path in this is to call
-PasteJob with mimedata. It could be dangling by this point.
-
-Pastejob follows a similar pattern in
-1d668a9fe65c5bc178487fc32e6662ff815147f6 internally but we also need to
-handle this usage before PasteJob.
-
-BUG: 454747
----
- src/widgets/dropjob.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/widgets/dropjob.cpp b/src/widgets/dropjob.cpp
-index fa2bf4ccc..5af578d28 100644
---- a/src/widgets/dropjob.cpp
-+++ b/src/widgets/dropjob.cpp
-@@ -139,7 +139,7 @@ public:
- void addPluginActions(KIO::DropMenu *popup, const KFileItemListProperties &itemProps);
- void doCopyToDirectory();
-
-- const QMimeData *m_mimeData;
-+ QPointer<const QMimeData> m_mimeData;
- const QList<QUrl> m_urls;
- QMap<QString, QString> m_metaData;
- Qt::DropAction m_dropAction;
-@@ -271,7 +271,7 @@ void DropJobPrivate::slotStart()
- q->emitResult();
- }
- }
-- } else {
-+ } else if (m_mimeData) {
- // Dropping raw data
- KIO::PasteJob *job = KIO::PasteJobPrivate::newJob(m_mimeData, m_destUrl, KIO::HideProgressInfo, false /*not clipboard*/);
- QObject::connect(job, &KIO::PasteJob::itemCreated, q, &KIO::DropJob::itemCreated);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.96.0-with_x11.patch b/kde-frameworks/kio/files/kio-5.96.0-with_x11.patch
deleted file mode 100644
index 9f87ec989af1..000000000000
--- a/kde-frameworks/kio/files/kio-5.96.0-with_x11.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From c7a277e6810b74b7f664b029573beab592932421 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Mon, 1 Aug 2022 22:10:02 +0200
-Subject: [PATCH] Drop obsolete X11 dependency, introduce WITH_X11 option
- instead
-
-This will only determine whether to search for Qt5X11Extras and then
-set HAVE_X11 accordingly. This is a behavior change as previously it was
-silently disabled if X11 was not found.
-
-We want to be able to build without X11 support even if some of the used
-libraries may not work w/o X11 themselves yet or need to be built with
-X11 support for other reverse dependencies.
-
-HAVE_X11 already exists and is set automagically so far, but using
--DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
-as required in their cmake config.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 19 +++++++++----------
- src/ioslaves/http/CMakeLists.txt | 3 ---
- 2 files changed, 9 insertions(+), 13 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 95b5db299..c3372f7ea 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -117,17 +117,16 @@ set_package_properties(GSSAPI PROPERTIES DESCRIPTION "Allows KIO to make use of
- PURPOSE "A MIT or HEIMDAL flavor of GSSAPI can be used"
- )
-
--if (NOT APPLE AND NOT WIN32)
-- find_package(X11)
--endif()
--
--set(HAVE_X11 ${X11_FOUND})
--if (HAVE_X11)
-- if (QT_MAJOR_VERSION STREQUAL "5")
-- find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED X11Extras)
-- else()
-- # qtx11extras_p.h is in Qt6Gui, which is implied by the find_package(QtWidgets) above
-+if (NOT APPLE AND NOT WIN32 AND NOT ANDROID)
-+ option(WITH_X11 "Build with X11 integration" ON)
-+ if(WITH_X11)
-+ if (QT_MAJOR_VERSION STREQUAL "5")
-+ find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED X11Extras)
-+ else()
-+ # qtx11extras_p.h is in Qt6Gui, which is implied by the find_package(QtWidgets) above
-+ endif()
- endif()
-+ set(HAVE_X11 ${WITH_X11})
- endif()
-
- find_package(ACL)
-diff --git a/src/ioslaves/http/CMakeLists.txt b/src/ioslaves/http/CMakeLists.txt
-index 4fbddb4a3..689f63dd8 100644
---- a/src/ioslaves/http/CMakeLists.txt
-+++ b/src/ioslaves/http/CMakeLists.txt
-@@ -3,9 +3,6 @@ include(ECMMarkNonGuiExecutable)
- include(ConfigureChecks.cmake)
- configure_file(config-kioslave-http.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kioslave-http.h )
-
--find_package(X11)
--set(HAVE_X11 ${X11_FOUND})
--
- if(GSSAPI_FOUND)
- set(HAVE_LIBGSSAPI 1)
- if(GSSAPI_FLAVOR STREQUAL "MIT")
---
-GitLab
-