summaryrefslogtreecommitdiff
path: root/kde-frameworks/kio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /kde-frameworks/kio/files
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch79
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch105
2 files changed, 184 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch b/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch
new file mode 100644
index 000000000000..9cc0379b6998
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch
@@ -0,0 +1,79 @@
+From 581fab08ff4d5539e4684adcffc74ec3517ce29d Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Thu, 6 May 2021 21:26:31 +0200
+Subject: [PATCH] Remove the cache KCM
+
+Same reasoning as for
+https://invent.kde.org/frameworks/kio/-/merge_requests/438.
+
+It is very targeted towards KIO-based browsers which don't really exist
+any more.
+
+The setting is also global to everything that uses KIO and it's a bit
+questionable whether for example webdav browsing in Dolphin should
+automatically have the same cache settings as network access in Choqok.
+
+It being part of system settings is also confusing for users since it
+gives the false impression of true globality. They might expect it to
+affect Firefox or Webengine-based Konqueror which it does not.
+---
+ docs/kcontrol5/CMakeLists.txt | 1 -
+ src/kcms/kio/CMakeLists.txt | 4 +-
+ src/kcms/kio/main.cpp | 4 +-
+ 3 files changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/docs/kcontrol5/CMakeLists.txt b/docs/kcontrol5/CMakeLists.txt
+index 2dd1ae16a..6c2f21b07 100644
+--- a/docs/kcontrol5/CMakeLists.txt
++++ b/docs/kcontrol5/CMakeLists.txt
+@@ -1,4 +1,3 @@
+-add_subdirectory(cache)
+ add_subdirectory(cookies)
+ add_subdirectory(netpref)
+ add_subdirectory(proxy)
+diff --git a/src/kcms/kio/CMakeLists.txt b/src/kcms/kio/CMakeLists.txt
+index 11cd239f2..5281fc7dc 100644
+--- a/src/kcms/kio/CMakeLists.txt
++++ b/src/kcms/kio/CMakeLists.txt
+@@ -12,11 +12,9 @@ set(kcm_kio_PART_SRCS
+ smbrodlg.cpp
+ kproxydlg.cpp
+ netpref.cpp
+- cache.cpp
+ ksaveioconfig.cpp)
+
+ ki18n_wrap_ui(kcm_kio_PART_SRCS
+- cache.ui
+ kproxydlg.ui
+ kcookiespolicies.ui
+ kcookiesmanagement.ui
+@@ -41,5 +39,5 @@ install(TARGETS kcm_kio DESTINATION ${KDE_INSTALL_PLUGINDIR} )
+
+ ########### install files ###############
+
+-install( FILES smb.desktop cookies.desktop cache.desktop
++install( FILES smb.desktop cookies.desktop
+ netpref.desktop proxy.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
+diff --git a/src/kcms/kio/main.cpp b/src/kcms/kio/main.cpp
+index 8bacb10ca..2c0ebc29b 100644
+--- a/src/kcms/kio/main.cpp
++++ b/src/kcms/kio/main.cpp
+@@ -13,7 +13,6 @@
+ #include <KPluginFactory>
+
+ // Local
+-#include "cache.h"
+ #include "kcookiesmain.h"
+ #include "kproxydlg.h"
+ #include "netpref.h"
+@@ -21,7 +20,6 @@
+
+ K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<SMBRoOptions>(QStringLiteral("smb")); registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
+ registerPlugin<KProxyDialog>(QStringLiteral("proxy"));
+- registerPlugin<KCookiesMain>(QStringLiteral("cookie"));
+- registerPlugin<CacheConfigModule>(QStringLiteral("cache"));)
++ registerPlugin<KCookiesMain>(QStringLiteral("cookie"));)
+
+ #include "main.moc"
+--
+GitLab
diff --git a/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch b/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch
new file mode 100644
index 000000000000..ce0e891e9164
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch
@@ -0,0 +1,105 @@
+From 1aa42558a0f539abfe4bc92cf2c8078ac4adb9a0 Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Wed, 5 May 2021 22:27:25 +0200
+Subject: [PATCH] Remove the Browser Identification KCM
+
+It's purpose is to control the user agent used by kio-http.
+
+Very few things use kio-http these days, not even Konqueror with the
+webengine part.
+
+For the remaining use cases (kioclient, webdav kio worker, etc.) this
+kind of configurability is overkill.
+
+Moreover being part of systemsettings this gives a false impression of
+globality. A user might change something in there and wonder why it does
+not apply to Firefox or Falkon.
+
+Given the questionable usefulness and the potential for confusion I
+propose to remove it entirely.
+---
+ docs/kcontrol5/CMakeLists.txt | 1 -
+ src/kcms/kio/CMakeLists.txt | 18 +-
+ src/kcms/kio/main.cpp | 4 +-
+ 3 files changed, 2 insertions(+), 21 deletions(-)
+
+diff --git a/docs/kcontrol5/CMakeLists.txt b/docs/kcontrol5/CMakeLists.txt
+index 1b19e5e7b..2dd1ae16a 100644
+--- a/docs/kcontrol5/CMakeLists.txt
++++ b/docs/kcontrol5/CMakeLists.txt
+@@ -4,5 +4,4 @@ add_subdirectory(netpref)
+ add_subdirectory(proxy)
+ add_subdirectory(smb)
+ add_subdirectory(trash)
+-add_subdirectory(useragent)
+ add_subdirectory(webshortcuts)
+diff --git a/src/kcms/kio/CMakeLists.txt b/src/kcms/kio/CMakeLists.txt
+index a354651b0..11cd239f2 100644
+--- a/src/kcms/kio/CMakeLists.txt
++++ b/src/kcms/kio/CMakeLists.txt
+@@ -1,6 +1,4 @@
+
+-add_subdirectory( uasproviders )
+-
+ find_package(KF5TextWidgets ${KF_DEP_VERSION} REQUIRED)
+
+ ########### next target ###############
+@@ -12,31 +10,18 @@ set(kcm_kio_PART_SRCS
+ kcookiesmanagement.cpp
+ kcookiespolicyselectiondlg.cpp
+ smbrodlg.cpp
+- useragentdlg.cpp
+ kproxydlg.cpp
+- useragentinfo.cpp
+- useragentselectordlg.cpp
+ netpref.cpp
+ cache.cpp
+ ksaveioconfig.cpp)
+
+ ki18n_wrap_ui(kcm_kio_PART_SRCS
+ cache.ui
+- useragentselectordlg.ui
+- useragentdlg.ui
+ kproxydlg.ui
+ kcookiespolicies.ui
+ kcookiesmanagement.ui
+ kcookiespolicyselectiondlg.ui)
+
+-ecm_qt_export_logging_category(
+- IDENTIFIER KIO_USERAGENTDLG
+- CATEGORY_NAME kf.configwidgets.cms.kf.kio.useragentdlg
+- OLD_CATEGORY_NAMES kf5.kio.useragentdlg
+- DESCRIPTION "kio useragentdialog (KIO)"
+- EXPORT KIO
+-)
+-
+ add_library(kcm_kio MODULE ${kcm_kio_PART_SRCS})
+
+ target_link_libraries(kcm_kio
+@@ -56,6 +41,5 @@ install(TARGETS kcm_kio DESTINATION ${KDE_INSTALL_PLUGINDIR} )
+
+ ########### install files ###############
+
+-install( FILES smb.desktop cookies.desktop useragent.desktop cache.desktop
++install( FILES smb.desktop cookies.desktop cache.desktop
+ netpref.desktop proxy.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
+-install( FILES uasprovider.desktop DESTINATION ${KDE_INSTALL_KSERVICETYPES5DIR} )
+diff --git a/src/kcms/kio/main.cpp b/src/kcms/kio/main.cpp
+index f1b065f46..8bacb10ca 100644
+--- a/src/kcms/kio/main.cpp
++++ b/src/kcms/kio/main.cpp
+@@ -18,10 +18,8 @@
+ #include "kproxydlg.h"
+ #include "netpref.h"
+ #include "smbrodlg.h"
+-#include "useragentdlg.h"
+
+-K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<UserAgentDlg>(QStringLiteral("useragent")); registerPlugin<SMBRoOptions>(QStringLiteral("smb"));
+- registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
++K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<SMBRoOptions>(QStringLiteral("smb")); registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
+ registerPlugin<KProxyDialog>(QStringLiteral("proxy"));
+ registerPlugin<KCookiesMain>(QStringLiteral("cookie"));
+ registerPlugin<CacheConfigModule>(QStringLiteral("cache"));)
+--
+GitLab
+