summaryrefslogtreecommitdiff
path: root/kde-frameworks/ki18n/ki18n-5.82.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /kde-frameworks/ki18n/ki18n-5.82.0.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.82.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.82.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.82.0.ebuild b/kde-frameworks/ki18n/ki18n-5.82.0.ebuild
new file mode 100644
index 000000000000..c163b404f540
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.82.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.57.0-python.patch" )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}