summaryrefslogtreecommitdiff
path: root/kde-frameworks/kdesu/kdesu-5.102.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
commitbdc9b55c978e3939e16252e66e83950cbecbf77c (patch)
treeabab17826fc88c33d1b30eadaec18fcc6f2efb14 /kde-frameworks/kdesu/kdesu-5.102.0.ebuild
parent3bd85407abc9ed4434c2d3741f84fdb512638b1c (diff)
gentoo auto-resync : 15:01:2023 - 05:54:04
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.102.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.102.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.102.0.ebuild b/kde-frameworks/kdesu/kdesu-5.102.0.ebuild
new file mode 100644
index 000000000000..d5ebea58648d
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.102.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}