summaryrefslogtreecommitdiff
path: root/kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild')
-rw-r--r--kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild
new file mode 100644
index 000000000000..bbb98d443d69
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.67.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_QTHELP="false"
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing plugins to use KDE frameworks widgets in QtDesigner"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"