summaryrefslogtreecommitdiff
path: root/kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild')
-rw-r--r--kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild b/kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild
new file mode 100644
index 000000000000..83a54db4fae1
--- /dev/null
+++ b/kde-frameworks/kdbusaddons/kdbusaddons-5.37.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALDBUS_TEST="true"
+inherit kde5
+
+DESCRIPTION="Framework for registering services and applications per freedesktop standards"
+LICENSE="LGPL-2+"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="nls X"
+
+RDEPEND="
+ $(add_qt_dep qtdbus)
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X Qt5X11Extras)
+ )
+
+ kde5_src_configure
+}