summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcrash/kcrash-5.57.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /kde-frameworks/kcrash/kcrash-5.57.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.57.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.57.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.57.0.ebuild b/kde-frameworks/kcrash/kcrash-5.57.0.ebuild
new file mode 100644
index 000000000000..59a1d61a4977
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.57.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( $(add_qt_dep qtwidgets) )
+"