summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcrash/kcrash-5.116.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
commit77b275a53383b07b154caa09feb6f4961b206638 (patch)
treebf2b88f1f848dfe69541c3d78aaa35ef22560107 /kde-frameworks/kcrash/kcrash-5.116.0.ebuild
parent9d4810f84de876ec9d0ae03d0d44224500b41188 (diff)
gentoo auto-resync : 20:05:2024 - 00:02:15
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.116.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.116.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.116.0.ebuild b/kde-frameworks/kcrash/kcrash-5.116.0.ebuild
new file mode 100644
index 000000000000..b62e3f0b5992
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.116.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}