summaryrefslogtreecommitdiff
path: root/kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild')
-rw-r--r--kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild
new file mode 100644
index 000000000000..33c40898024d
--- /dev/null
+++ b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.60.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing an assortment of configuration-related widgets"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+man"
+
+BDEPEND="
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}