summaryrefslogtreecommitdiff
path: root/kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:24:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:24:29 +0100
commit85b4dac8f08d6690d531e17fafe23f30ecb4064f (patch)
tree259bae2cf2a79c9da4fdbf47746e86a39f09828a /kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild
parent907e9d90c393da55ed9e9edeb2a81fa5c3fdce31 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild')
-rw-r--r--kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild
new file mode 100644
index 000000000000..1c61d3a252eb
--- /dev/null
+++ b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.48.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing an assortment of configuration-related widgets"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+man"
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}