summaryrefslogtreecommitdiff
path: root/kde-frameworks/kconfig/kconfig-5.67.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /kde-frameworks/kconfig/kconfig-5.67.0.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'kde-frameworks/kconfig/kconfig-5.67.0.ebuild')
-rw-r--r--kde-frameworks/kconfig/kconfig-5.67.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kconfig/kconfig-5.67.0.ebuild b/kde-frameworks/kconfig/kconfig-5.67.0.ebuild
new file mode 100644
index 000000000000..9247f6ac4c1a
--- /dev/null
+++ b/kde-frameworks/kconfig/kconfig-5.67.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for reading and writing configuration"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="dbus nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ dbus? ( >=dev-qt/qtdbus-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+
+# bug 560086
+RESTRICT+=" test"
+
+DOCS=( DESIGN docs/DESIGN.kconfig docs/options.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKCONFIG_USE_DBUS=$(usex dbus)
+ )
+ ecm_src_configure
+}