summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild')
-rw-r--r--kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild b/kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild
new file mode 100644
index 000000000000..a624d4944065
--- /dev/null
+++ b/kde-frameworks/kcodecs/kcodecs-5.86.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for manipulating strings using various encodings"
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/gperf
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}