summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild')
-rw-r--r--kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild b/kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild
new file mode 100644
index 000000000000..e6daae33a2d8
--- /dev/null
+++ b/kde-frameworks/kcmutils/kcmutils-5.45.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORK_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework to work with KDE System Settings modules"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}"