summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
commit519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (patch)
tree7e99d88a777fe8c9d3ec6310bf7eea639b0e66b4 /kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild
parenta5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (diff)
gentoo resync : 12.11.2017
Diffstat (limited to 'kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild')
-rw-r--r--kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild b/kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild
new file mode 100644
index 000000000000..3bf55741864c
--- /dev/null
+++ b/kde-frameworks/kcmutils/kcmutils-5.40.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORK_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework to work with KDE System Settings modules"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}"