summaryrefslogtreecommitdiff
path: root/kde-frameworks/kauth/kauth-5.99.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
commitbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (patch)
tree4a2377c9096a6e85935bc1b24a50c09537fbb3ca /kde-frameworks/kauth/kauth-5.99.0.ebuild
parentf69024d0d689548234c6173dc2d8a5bb466b0525 (diff)
gentoo auto-resync : 10:10:2022 - 13:34:00
Diffstat (limited to 'kde-frameworks/kauth/kauth-5.99.0.ebuild')
-rw-r--r--kde-frameworks/kauth/kauth-5.99.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/kauth-5.99.0.ebuild b/kde-frameworks/kauth/kauth-5.99.0.ebuild
new file mode 100644
index 000000000000..9253dd27e63a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.99.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}