summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:24:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:24:29 +0100
commit85b4dac8f08d6690d531e17fafe23f30ecb4064f (patch)
tree259bae2cf2a79c9da4fdbf47746e86a39f09828a /kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
parent907e9d90c393da55ed9e9edeb2a81fa5c3fdce31 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
new file mode 100644
index 000000000000..b6c0da034de8
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}