summaryrefslogtreecommitdiff
path: root/kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild')
-rw-r--r--kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild b/kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild
new file mode 100644
index 000000000000..adc7a124e0af
--- /dev/null
+++ b/kde-frameworks/bluez-qt/bluez-qt-5.45.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5 udev
+
+DESCRIPTION="Qt wrapper for Bluez 5 DBus API"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtnetwork)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d"
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bug: 609248
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}