summaryrefslogtreecommitdiff
path: root/kde-frameworks/baloo/baloo-5.64.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /kde-frameworks/baloo/baloo-5.64.0.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'kde-frameworks/baloo/baloo-5.64.0.ebuild')
-rw-r--r--kde-frameworks/baloo/baloo-5.64.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/baloo/baloo-5.64.0.ebuild b/kde-frameworks/baloo/baloo-5.64.0.ebuild
new file mode 100644
index 000000000000..f6b87f1460ef
--- /dev/null
+++ b/kde-frameworks/baloo/baloo-5.64.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for searching and managing metadata"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+ >=kde-frameworks/kcrash-${PVCUT}:5
+ >=kde-frameworks/kdbusaddons-${PVCUT}:5
+ >=kde-frameworks/kfilemetadata-${PVCUT}:5
+ >=kde-frameworks/ki18n-${PVCUT}:5
+ >=kde-frameworks/kidletime-${PVCUT}:5
+ >=kde-frameworks/kio-${PVCUT}:5
+ >=kde-frameworks/solid-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-db/lmdb-0.9.17
+"
+RDEPEND="${DEPEND}
+ !kde-frameworks/baloo:4[-minimal(+)]
+"
+
+RESTRICT+=" test" # bug 624250