summaryrefslogtreecommitdiff
path: root/kde-frameworks/attica/attica-5.104.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
commit8fa69fdd0836c0b856dd0f9ef77d5fb25df844ec (patch)
tree5b2388d462e1ce30c6c01d22c809fab8b5beee8f /kde-frameworks/attica/attica-5.104.0.ebuild
parent23650861e24563ddcf10919ab5b1912676c3ff0c (diff)
gentoo auto-resync : 12:03:2023 - 00:09:21
Diffstat (limited to 'kde-frameworks/attica/attica-5.104.0.ebuild')
-rw-r--r--kde-frameworks/attica/attica-5.104.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/attica/attica-5.104.0.ebuild b/kde-frameworks/attica/attica-5.104.0.ebuild
new file mode 100644
index 000000000000..23ac40a18655
--- /dev/null
+++ b/kde-frameworks/attica/attica-5.104.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing access to Open Collaboration Services"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtnetwork-${QTMIN}:5
+"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ # requires network access, bug #661230
+ local myctestargs=(
+ -E "(providertest)"
+ )
+
+ ecm_src_test
+}