summaryrefslogtreecommitdiff
path: root/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'kde-apps/yakuake/yakuake-3.0.5-r1.ebuild')
-rw-r--r--kde-apps/yakuake/yakuake-3.0.5-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..afa2667addc2
--- /dev/null
+++ b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://yakuake.kde.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patches.tar.xz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+IUSE="absolute-position X"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep konsole)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ absolute-position? ( $(add_frameworks_dep kwayland) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/yakuake:4
+"
+
+PATCHES=( "${WORKDIR}/${P}-patches" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package absolute-position KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}