summaryrefslogtreecommitdiff
path: root/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild')
-rw-r--r--kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild b/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
new file mode 100644
index 000000000000..9214a476dec9
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:5
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ ecm_src_configure
+}