summaryrefslogtreecommitdiff
path: root/kde-apps/plasma-telepathy-meta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-apps/plasma-telepathy-meta
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-apps/plasma-telepathy-meta')
-rw-r--r--kde-apps/plasma-telepathy-meta/Manifest4
-rw-r--r--kde-apps/plasma-telepathy-meta/metadata.xml8
-rw-r--r--kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.04.3.ebuild38
-rw-r--r--kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.08.1.ebuild33
4 files changed, 83 insertions, 0 deletions
diff --git a/kde-apps/plasma-telepathy-meta/Manifest b/kde-apps/plasma-telepathy-meta/Manifest
new file mode 100644
index 000000000000..4db97438a62b
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/Manifest
@@ -0,0 +1,4 @@
+EBUILD plasma-telepathy-meta-17.04.3.ebuild 1093 SHA256 981a149851f31eb5d377973aba474a2c84a993ca1eaa9aa82243ea1601b676de SHA512 f80dfcfa5199f58687e5802d850c9d21171805b9c0188b7a4919598df2f072dea4f97421908adeadef37fb0877076d732a98ca7217f761e96c48705ad8b8104c WHIRLPOOL ffaaa98f01752ef1317c755c1c3f2ca5001c1ab8e60c057128b18980b5a41981df07152cc9bfe4725f4f835025b3b9e00c1416b15b235db87a04214de075b3be
+EBUILD plasma-telepathy-meta-17.08.1.ebuild 938 SHA256 66cded51ad2e28d974f33b4e1683256671ee7d3bf0da018b6bb0601b8c5261ef SHA512 d539629e88e73375e2418b111979689d39070b7d677744cf4b059ab572e53a1c46d849a2fe148c266edc3fc16e7ba358db9f68905c65a8601fea747950520ffc WHIRLPOOL 0688b452220a07dcabc59a4ee40c22358627432e7ba6eed6ba942c6897d58664c11f8c4d961414f58611cfc604c25bbdb42f1a680aa590e192d71fff9d11f346
+MISC ChangeLog 3621 SHA256 338cf604e4b345c516ef07ad0db9a5387b8cba45fc6ce1b427668f5ed4e326ef SHA512 2ee2e1f436ee6389a6afeccd42bdafc090d59a9315bc6da3902246f6536b8e03e97afa5adfb765807029cf6564cfdfa683c1211f1f39a9f3dcd02e6391f7b4a8 WHIRLPOOL 719127d33ed1e8f8f214e2b4b73151db2af4fee07540785539eff4c133508a706cf80f56f9dad8b6c49172138b9cb444f1cf0418e68da0292e5d0c9adfb8c99d
+MISC metadata.xml 249 SHA256 584f1dcf51866dc24a9abf7a89bfba0fad11dde81ae1c1b715da41770d233c99 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3 WHIRLPOOL 200c07a8bf7c55b11b7936d5cd30e991a511684913334e72f59def66c0ced5fed0b4a8754e2d98bffbab631cb90d4e17fcccc59d5dcc5a8e988f69e47c85518c
diff --git a/kde-apps/plasma-telepathy-meta/metadata.xml b/kde-apps/plasma-telepathy-meta/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.04.3.ebuild b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.04.3.ebuild
new file mode 100644
index 000000000000..3dd002cea44a
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.04.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Plasma Telepathy client"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
+KEYWORDS="amd64 x86"
+IUSE="gstreamer nls"
+
+[[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
+
+RDEPEND="
+ $(add_kdeapps_dep ktp-accounts-kcm)
+ $(add_kdeapps_dep ktp-approver)
+ $(add_kdeapps_dep ktp-auth-handler)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_kdeapps_dep ktp-contact-list)
+ $(add_kdeapps_dep ktp-contact-runner)
+ $(add_kdeapps_dep ktp-desktop-applets)
+ $(add_kdeapps_dep ktp-filetransfer-handler)
+ $(add_kdeapps_dep ktp-kded-module)
+ $(add_kdeapps_dep ktp-send-file)
+ $(add_kdeapps_dep ktp-text-ui)
+ !kde-apps/plasma-telepathy-meta:4
+ gstreamer? ( $(add_kdeapps_dep ktp-call-ui) )
+"
+
+pkg_postinst() {
+ echo
+ elog "You can configure the accounts in Plasma System Settings"
+ elog "and then add the Instant Messaging plasma applet to access the contact list."
+ echo
+}
diff --git a/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.08.1.ebuild b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.08.1.ebuild
new file mode 100644
index 000000000000..d687eeb37175
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-17.08.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Plasma Telepathy client"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(add_kdeapps_dep ktp-accounts-kcm)
+ $(add_kdeapps_dep ktp-approver)
+ $(add_kdeapps_dep ktp-auth-handler)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_kdeapps_dep ktp-contact-list)
+ $(add_kdeapps_dep ktp-contact-runner)
+ $(add_kdeapps_dep ktp-desktop-applets)
+ $(add_kdeapps_dep ktp-filetransfer-handler)
+ $(add_kdeapps_dep ktp-kded-module)
+ $(add_kdeapps_dep ktp-send-file)
+ $(add_kdeapps_dep ktp-text-ui)
+ gstreamer? ( $(add_kdeapps_dep ktp-call-ui) )
+"
+
+pkg_postinst() {
+ elog "You can configure the accounts in Plasma System Settings"
+ elog "and then add the Instant Messaging plasma applet to access the contact list."
+}