summaryrefslogtreecommitdiff
path: root/kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild')
-rw-r--r--kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild b/kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild
new file mode 100644
index 000000000000..0e3ac8470927
--- /dev/null
+++ b/kde-apps/pim-data-exporter/pim-data-exporter-22.04.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.4
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Assistant to backup and archive PIM data and configuration"
+HOMEPAGE="https://apps.kde.org/pimdataexporter/
+https://userbase.kde.org/KMail/Backup_Options"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="telemetry"
+
+RESTRICT="test" # 11 out of 21 tests fail...
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ telemetry? ( >=dev-libs/kuserfeedback-1.2.0:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ ecm_src_configure
+}