summaryrefslogtreecommitdiff
path: root/kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild')
-rw-r--r--kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild b/kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild
new file mode 100644
index 000000000000..99d66a5228ff
--- /dev/null
+++ b/kde-apps/ktp-auth-handler/ktp-auth-handler-17.04.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy authentication handler"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ app-crypt/qca:2[qt5]
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-17.04.2-no-qtwebkit.patch" )