summaryrefslogtreecommitdiff
path: root/kde-apps/kontact/kontact-22.08.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
commit924750a8c767b278c9870be5dcfedced436f1276 (patch)
treed5c93de95fb5c2fa090e76fd12c1535698005868 /kde-apps/kontact/kontact-22.08.3.ebuild
parenta4d4c6a7cf31d8d3248101dbfd654cdc416902ac (diff)
gentoo auto-resync : 03:11:2022 - 21:12:43
Diffstat (limited to 'kde-apps/kontact/kontact-22.08.3.ebuild')
-rw-r--r--kde-apps/kontact/kontact-22.08.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/kontact/kontact-22.08.3.ebuild b/kde-apps/kontact/kontact-22.08.3.ebuild
new file mode 100644
index 000000000000..028f36166dd5
--- /dev/null
+++ b/kde-apps/kontact/kontact-22.08.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Container application to unify several major PIM applications within one"
+HOMEPAGE="https://kontact.kde.org/ https://apps.kde.org/kontact/"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"