summaryrefslogtreecommitdiff
path: root/kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
commitd5599da3055bf9b900513a61c3c6e4bdbb524503 (patch)
treeb64a792286dd490c9d4fc2c46bbbaa64804efc61 /kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild
parentcfeee79886441e92c8ee094e45b9bcdc9c79137a (diff)
gentoo auto-resync : 08:06:2023 - 15:45:39
Diffstat (limited to 'kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild')
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild b/kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild
new file mode 100644
index 000000000000..037d88f4b3e1
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-23.04.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.104.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ rm -f po/*/calendarjanitor.po || die
+
+ cmake_comment_add_subdirectory calendarjanitor
+}