summaryrefslogtreecommitdiff
path: root/kde-apps/konsole/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
commit7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (patch)
tree0b0cd08ce6e24faf7c868b07127ee0b6b32153c7 /kde-apps/konsole/files
parentda3552023d9aae2ee5183df71a80a8169414974e (diff)
gentoo auto-resync : 06:08:2022 - 14:10:01
Diffstat (limited to 'kde-apps/konsole/files')
-rw-r--r--kde-apps/konsole/files/konsole-22.04.3-without_x11.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..ed396fcf20ab
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
@@ -0,0 +1,46 @@
+From 0aa39e22a2bb1bbcb8a02dfd6635ffe4d8a0bbb1 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 14:43:18 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 61ed70cd7..565682848 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,10 +103,13 @@ set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
+ )
+
+ if(NOT APPLE)
+- find_package(X11)
+- set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++ if (NOT WITHOUT_X11)
++ find_package(X11)
++ set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ set(HAVE_X11 ${X11_FOUND})
++ endif()
+ endif()
+-set(HAVE_X11 ${X11_FOUND})
+
+ # Check for function GETPWUID
+ check_symbol_exists(getpwuid "pwd.h" HAVE_GETPWUID)
+--
+GitLab
+