summaryrefslogtreecommitdiff
path: root/kde-apps/kimap/kimap-23.08.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-12 18:15:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-12 18:15:25 +0100
commit36c436b12f9ef2523e5fd963381b78d2dc5cc53d (patch)
treef275068802d3c71dcdd97439f906e36237263361 /kde-apps/kimap/kimap-23.08.2.ebuild
parent3a0e100e02e1c6c2818268f57eae51095cee35af (diff)
gentoo auto-resync : 12:10:2023 - 18:15:24
Diffstat (limited to 'kde-apps/kimap/kimap-23.08.2.ebuild')
-rw-r--r--kde-apps/kimap/kimap-23.08.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/kimap/kimap-23.08.2.ebuild b/kde-apps/kimap/kimap-23.08.2.ebuild
new file mode 100644
index 000000000000..cca57be6689f
--- /dev/null
+++ b/kde-apps/kimap/kimap-23.08.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for interacting with IMAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kimap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+# TODO: Convince upstream not to install stuff with tests
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+ ecm_src_test
+}