summaryrefslogtreecommitdiff
path: root/kde-apps/kholidays/kholidays-17.08.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:23:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:23:15 +0100
commit6e0dec7ba4f6c5793a3d0b85952efa7ec57afa65 (patch)
treedcf170f6adae0db9a35f68683c81d68edfc54158 /kde-apps/kholidays/kholidays-17.08.2.ebuild
parentab58e299fd6dae92ea274fe7d0ad685d888a51b7 (diff)
gentoo resync : 12.10.2017
Diffstat (limited to 'kde-apps/kholidays/kholidays-17.08.2.ebuild')
-rw-r--r--kde-apps/kholidays/kholidays-17.08.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-apps/kholidays/kholidays-17.08.2.ebuild b/kde-apps/kholidays/kholidays-17.08.2.ebuild
new file mode 100644
index 000000000000..c434c031139d
--- /dev/null
+++ b/kde-apps/kholidays/kholidays-17.08.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library to determine holidays and other special events for a geographical region"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_qt_dep qtdeclarative)
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_test() {
+ # bug 624214
+ mkdir -p "${HOME}/.local/share/kf5/libkholidays" || die
+ cp -r "${S}/holidays/plan2" "${HOME}/.local/share/kf5/libkholidays/" || die
+ kde5_src_test
+}